Nissan Kicks Forum banner
1 - 12 of 12 Posts

· Registered
Joined
·
4 Posts
Those are indicators for your collision avoidance system. At least my car, 2020 SV, will not go in reverse if there is an "obstruction". Try disabling your collision avoidance system and see if it will go in reverse.
And then make an appointment with the dealer to get it fixed.
I have the Nissan kicks 2019 SV and had nothing but issues ,system issues just spent 3k on new transmission ,constantly getting warning lights ,will never get another one
 

· Registered
Joined
·
2 Posts
2018 Kicks. Does anyone know what this symbol is? I know one is the automatic brake. Is it the forward sensor? Why would the car not go while in reverse now? Very confusing
2018 Kicks. Does anyone know what this symbol is? I know one is the automatic brake. Is it the forward sensor? Why would the car not go while in reverse now? Very confusing
My car is doing the same thing. Did you have yours looked at. Curious to know what you are being told is wrong?
 

· Registered
Joined
·
4 Posts
Is it safe to say you are in a snow area? I am having same issues and I just bought mine...
I was told that the snow blocks the sensors causing these lights to come on. I guess it's just a summer car?
Good luck!
 

· Registered
Joined
·
2 Posts
Is it safe to say you are in a snow area? I am having same issues and I just bought mine...
I was told that the snow blocks the sensors causing these lights to come on. I guess it's just a summer car?
Good luck!
When I first bought my car my front sensor did that. They replaced it because it was doing it in perfect weather conditions also. It took a while for them to get a code.
 

· Registered
Joined
·
2 Posts
2018 Kicks. Does anyone know what this symbol is? I know one is the automatic brake. Is it the forward sensor? Why would the car not go while in reverse now? Very confusing
My 2020 kicks did this right after I drove it off the lot, but the third time I was in the Drive-Thru and the entire front and side camera grid on the screen were lit up and flashing. It was dark. While it was doing this and I was parked it would hardly move until I shut the car off and started it again. It really seemed to only do it in dark conditions, foggy windows and during the rain it would complain about a possible crash. Not all the time though and never in the daytime. I took it in to be seen and they couldn't find anything wrong. There were no codes of course. I took it in again and they put the car on a troubleshooting program and when I got it back it was better, but did it a couple more times. The car was running crappie and had no power, but when I got it back after the troubleshooting it was like a whole new car. More power. That was a pleasant surprise, because these are famous for not having power with such a tiny engine. So anyway the Tech said it is an ongoing problem with the front sensor and basically nothing they can do. I traded it in soon as I could for a 2022 Sentra and I'm totally happy. I'm telling you guys, insist on them putting it on a troubleshooting program. You may get a whole new car back
 

· Registered
Joined
·
6 Posts
Based on the RPM gauge in your picture, your car is not even running. Until the car is running, it is normal the lights to stay on.
I'm wondering if this is similar to the weird not-even-limp mode that I've experienced twice now. Both times below -25C. Car starts, all the collision lights and engine light are on. But no response from throttle so the car won't move. I think I have to let it warm up a bit. Turn it off and let it sit for 5+ minutes and then try again (both times it started and ran fine the next morning).

Not impressed with the Kicks for the frozen land of Hoth (as AvE calls this place)
 
1 - 12 of 12 Posts
Top