Nissan Kicks Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi there,

Got my Nissan kicks 2019 sv recently. Unfortunately, after you start the car a go few meters, it beeps and shows warning “front radar obstruction” .

i checked on internet about it, and I found out that it’s ok to drive it while that warning shows.

i continued to drive it that way till today. When i start car, it’s now saying “malfunction, see owners manual”, then i have to go to vehicle settings and turn off “front brake system”.

its very annoying to drive a car with such warnings, it shows yellow two car crasing icon.

i want suggestions from you please help. If there is a fuse to remove, cables to disconnect or whatever I should do please suggest me.
I recently bought the car and it’s annoying this happens to me everyday.

thanks in advance.
 

·
Registered
2020 Nissan Kicks SV
Joined
·
61 Posts
Hey Omrov, did you buy the car used from a dealer or private sale? This will determine next step.
Sounds like a defective sensor. But some general troubleshooting:
Depending on your local provincial laws, you may have a front license plate. The dealer generally mounts one to the front bumper. Check that the front plate does not cover a sensor. Check that the mounting screw has not broken any wires.
If you have any front accessories including a bra, remove them and try again.
Check that the sensor has not fallen out of place. Sound like you got a used car. Possibly the previous owner had a fender bender and the sensor could have fallen?

Further this wouldn't be a fuse issue, as the sensor is clearly reporting to the computer. You can check the fuse panel under the hood, but I do not recall seeing one on my 2020.

If you bought the car from a dealer, take it back immediately, and have them fix it. If you bought it private, you are gonna be on the hook for repairs.
 

·
Registered
Joined
·
10 Posts
Hey Omrov, did you buy the car used from a dealer or private sale? This will determine next step.
Sounds like a defective sensor. But some general troubleshooting:
Depending on your local provincial laws, you may have a front license plate. The dealer generally mounts one to the front bumper. Check that the front plate does not cover a sensor. Check that the mounting screw has not broken any wires.
If you have any front accessories including a bra, remove them and try again.
Check that the sensor has not fallen out of place. Sound like you got a used car. Possibly the previous owner had a fender bender and the sensor could have fallen?

Further this wouldn't be a fuse issue, as the sensor is clearly reporting to the computer. You can check the fuse panel under the hood, but I do not recall seeing one on my 2020.

If you bought the car from a dealer, take it back immediately, and have them fix it. If you bought it private, you are gonna be on the hook for repairs.
My 2018 Kicks started doing that. I had the extended warranty and the dealer replaced the rather expensive front radar unit free. Normally the part would be something like $1200 from what I was told.
Incidentally, this is the first car I’ve owned that I’m glad to have the extra warranty. They have covered several costly repairs including most recently both front struts. Springs broke on both. The car is coming up on 110,000 miles now so I’m not too surprised.
 
1 - 3 of 3 Posts
Top