Nissan Kicks Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I'm revving past 4000RPM and it just took me 20secs to get from 20km/hr to 45km/hr. Quite the scare merging onto the Highway after work I must say! Vehicle will be towed to the dealership tomorrow am.

Once on the highway I got up to 70km/hr and she wouldn't want to climb much more than that. 4 Flashers were in effect.

I know the acceleration is not the selling point on this car but clearly we have a CVT/Acceleration issue on our hands. Anyone experience this snag?
 

·
Registered
Joined
·
58 Posts
No issues here. Acceleration is quite decent on mine. Took mine to 140kph a few times. :wink
Cruising around 110kph should only be around 2000rpm.



Only thing I could think off is that the shiftier maybe on L?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
Wasn't on L. Definitely a CVT issue on my end. I'll keep ya's posted what the dealer say's tomorrow.
 

·
Registered
Joined
·
79 Posts
Yes does sound like a CVT issue, when my alternator died couple weeks back, that was the first indication it was just about to all go wrong.
I had low forward speed but lots of revs, not long after just about ever warning light came on.
So maybe a voltage issue. Once voltage gets to about 10volts the ecm start acting up
Hope dealer can get it sorted.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
Got my Kicks back from the dealer this morning. The issue was fixed by resetting the computer. They didn't even turn a wrench, was all computer. Works like a charm but its kinda sketchy to find out a computer issue could cause this.
 

·
Registered
Joined
·
58 Posts
Got my Kicks back from the dealer this morning. The issue was fixed by resetting the computer. They didn't even turn a wrench, was all computer. Works like a charm but its kinda sketchy to find out a computer issue could cause this.

Glad to hear that it is an easy fix. Did they show you how to reboot it, in case it happens again?

Computers rule the world. :|
 

·
Registered
Joined
·
79 Posts
Had a similar issue this morning.
Could not get up to highway speed, wasn't as bad as yours but could not get passed 100 kph had 5500 revs with pedal on floor but no increase in speed, one point down to 80kph with pedal flat on floor and screaming the engine.
Going into dealer yet again for its 4 visit in as many weeks.
Opened a Nissan customer care case, as starting to get annoyed with these issues.
 

·
Registered
Joined
·
1 Posts
KickA55 and HandyAndy


I am having the same problem with mine, but it seems to be a cold weather issue. It happened this past weekend when temps first dipped below -15C The dealer here in Saskatoon has replaced a control unit twice, last winter when it was happening and now it has happened on this third unit.



KicksA55 - did yours happen in cold weather?


Ryan
 

·
Registered
Joined
·
79 Posts
The kicks is not a winter car.
Soon as it starts to get cold the CVT starts to act up.
Last year the oil breather system froze and blow oil all other the engine bay.
As my one is a lease car don't even bother any more to take into dealer, more a design issue than a mechanical issue.
I found that Nissan in general are not winter cars.
Had 3 different models when my Kicks was in the shop for repairs ,lack of heat from the heater and tranny issue seemed to be common issue
I am up in Prince Albert, so we are similar weather.
Wish we have good lemon laws like the states, for sure my one would of gone back for sure.
Open a customer care case if nothing else you might get some money put aside at your dealer for future service work
 
1 - 10 of 10 Posts
Top