Nissan Kicks Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
My 2021 Nissan kicks has 74 miles on it. I told the dealer that GPS was non negotiable...an absolute MUST for me. He couldn't set it up for me at the showroom because "I didn't have a cord".
My son downloaded the app onto my phone and set it up on my car. It(Android auto) only worked when plugged in and only 3 times. Now its quit. What do I do? Do I return the car? Hope the service team can fix it? What if its a lemon and other stuff starts breaking?
 

·
Registered
2020 Nissan Kicks SV
Joined
·
30 Posts
So Android Auto will only work when the device is plugged in. I recommend you check out the Android Auto website and maybe a few youtube videos to fully understand the application :)
My car does act up every now and then, and I have to unplug and replug my phone a couple times, OR unplug wait a while and plug back in. I think it is a glitch with the stereo system. As our cars can connect to wifi, I suggest either yourself or at the dealership, check for an update for the stereo system.

This is a bizarre glitch that I experience semi frequently, and no I have not updated my stereo yet :p
 

·
Registered
Joined
·
8 Posts
In addition to what sp3ctyrys said, it is worth noting that Android Auto can sometimes just be weird. I don't have any issues in my Kicks but did in my Golf. You may need to give it a few minutes to connect, that's what I had to do with my Golf after an android update on my phone.

As was stated above, you'll always need to have it plugged into your phone. It's a phone app that works with your infotainment system.
 

·
Registered
Joined
·
20 Posts
It sounds like an Android auto issue more than a car stereo issue. I have Apple car play and for the last year, I've had it glitch out once. I just unplugged and plug back in to fix the issue.
 

·
Registered
Joined
·
2 Posts
My 2021 Nissan kicks has 74 miles on it. I told the dealer that GPS was non negotiable...an absolute MUST for me. He couldn't set it up for me at the showroom because "I didn't have a cord".
My son downloaded the app onto my phone and set it up on my car. It(Android auto) only worked when plugged in and only 3 times. Now its quit. What do I do? Do I return the car? Hope the service team can fix it? What if its a lemon and other stuff starts breaking?
Since your car is still under warrantee... take it to the dealer and have them fix it or show you what you're doing wrong. I know with apple carplay I have to allow the app each time I plug it in on my phone. Check your phone and see if its prompting you for permissions.
 
1 - 5 of 5 Posts
Top